Archivo de la categoría: Misceláneas

Copiando web y correo de un server a otro

Tenía que migrar los contenidos de correo y de un sitio web de un server a otro, así que usé esta solución, todo desde consola:

1. Loguearse por ssh al nuevo server:

$ ssh root@nuevoserver.com

2. Ir hasta el directorio que contendrá el sitio web que quiero copiar, usualmente:

# cd /home/usuario/www

3. Conectarse por lftp al server remoto que tiene el sitio web que quiero copiar:

# lftp -u usuario sitioweb.com>

4. Pedirá el password  y al conectarse mostrará esto:

lftp usuario@sitioweb.com>

5. Ir hasta el directorio que contiene el sitio web que quiero copiar, usualmente:

lftp usuario@sitioweb.com> cd /home/user/www ( o solo cd www si el acceso nos llevase al directorio público y no a la raiz)

lftp usuario@sitioweb.com:/home/user/www>

6. Confirmar que el directorio está allí:

lftp usuario@sitioweb.com:/home/user/www> ls

drwxr-x–x  5 usuario grupo  4096 ago  3 06:12 sitioweb.com

7. Con la seguridad que se estaba en el directorio de destino (punto 2) antes de conectarse por lftp, hacer un mirror con la opción -v (para ver el proceso de copia):

lftp usuario@sitioweb.com:/home/usuario/www> mirror -v sitioweb.com

8. Terminada la copia salir del lftp:

lftp usuario@sitioweb.com:/home/user/www> quit

9. Verificar que el nuevo directorio ya esté en mi nuevo server:

root@nuevo [/home/usuario/www]#ls -l

drwxr-x–x 12 root root 4096 ago  3 12:58 sitioweb.com/

10. Observé que el directorio estaba, pero con propietario y grupo diferente a los existentes en mi nuevo server, así que los cambié con una única instrucción, usando -R para que el cambio afecte a todo el contenido, tanto directorios como archivos:

root@nuevoserver [/home/usuario/www]# chwon -R usuario:grupo sitioweb.com

11. Al listar nuevamente, confirmé el cambio:

drwxr-x–x 12 usuario grupo 4096 ago  3 12:58 sitioweb.com/

Listo, eso fue todo.
Para el correo hice exactamente lo mismo, el directorio del usuario de correo que me interesaba copiar estaba en /home/usuario/mail/sitioweb.com en el server antiguo, así que lo puse en el mismo directorio en el nuevo server usando mirror, conectado con lftp, y después me aseguré de cambiar propietario y grupo.

 

 

 

Configurar tarjeta de red en Ubuntu terminal

Comparto aquí mi ayuda de memoria, para configurar una tarjeta de red en Ubuntu ( Server 12.04 en mi caso), esto porque pasé mi disco a otra pc y al iniciar no había red:

Todo desde terminal o consola:

$ ifconfig  (mostrará la configuración de red, en mi caso no había ni eth0 ni ninguna otra eth)

$ ifconfig -a (mostrará el hardware de red, en mi caso mostró que había una eth1)

$ sudo ifconfig eht1 up (activará la eth1)

$ ifconfig (ahora sí incluyó la eth1 en la lista de configuración de red, pero sin IP)

$ sudo dhclient eth1

$ ifconfig (ahora la eth1 ya tiene IP recogido automáticamente del router al que estaba conectada mi pc)

Para que no tener que repetir los pasos anteriores en los siguientes arranques de la pc , hay que editar /etc/network/interfaces:

$ sudo nano /etc/network/interfaces

Y que quede así:

auto eth1
iface eth1 inet dhcp

Pero en mi caso, como no quería depender del router para tener una IP, la cual sería dinámica, le asigné una IP estática, editando el mismo archivo interfaces:

auto eth1
iface eth1 inet static
address 192.168.1.25
netmask 255.255.255.0
gateway 192.168.1.1

Finalmente reiniciamos el servicio de red:

$ sudo /etc/init.d/networking restart

$ ifconfig (ahora mostrará el nuevo IP estático que asignamos a la eth1)

Los DNS para conectar a internet pueden ser agregados o editados con:

$ sudo nano /etc/resolv.conf

 

 

 

Del nuevo Unity al clásico Gnome, fácilmente

Al igual que en sus últimas versiones, la versión 13.04 de Ubuntu vuelve a traer por defecto la interfaz gráfica Unity (Sí, esa con botones en barra lateral izquierda). Si necesitas, deseas o extrañas el antiguo Gnome (aquel con barra de menú arriba), puedes instalarlo sin afectar Unity y de allí en adelante tendrás la opción de escoger cual interfaz usarás en tu sesión.

  1. Abre una terminal o consola (Presiona al mismo tiempo Ctrl + Alt + T, para llamarla sin usar el mouse).
  2. Para instalar el antiguo Gnome usa: sudo apt-get install gnome-session-fallback.
  3. Cierra la sesión.
  4. En la ventana de inicio de sesión verás un ícono de Ubuntu, haz click en él para escoger la interfaz que usarás.
login_13-04_simple
Login Ubuntu 13.04 sin opciones
install_gnome_classic
Instalando Gnome Classic
login_13-04-_selector
Login 13.04 con selector de Interfaz

Orden cronológico inverso en plugin de comentarios de Facebook

El plugin de comentarios de Facebook por defecto muestra los comentarios por “Clasificación social”. Si queremos  que el “Orden cronológico inverso” sea el que se muestre por defecto (es decir el más reciente comentario encabeza la lista), tenemos que añadir una pequeña variable en el código que nos dió facebook para pegar el plugin (el código html), donde dice:

<div data-href=”http://example.com” data-width=”470″ data-num-posts=”2″></div>

agregar order_by=”reverse_time”, con lo cual queda así:

<div data-href=”http://example.com” data-width=”470″ data-num-posts=”2″ order_by=”reverse_time”></div>

Eso es todo.

Recuperando baterías (intentando)

trojan105Recibí 6 baterías marca Trojan modelo 105T. Estas son de 225 Ah y 6 v. Fueron instaladas hace 10 años por mí en un sistema de backup con un inversor Trace de 2 KVA, pero apenas si el sistema se usó un par de veces.

Estas baterías han estado desconectadas del Trace alrededor de un año. Revisàndolas encontré que las placas estaban húmedas pero el nivel de electrolito no llegaba a cubrirlas; el voltaje en todas era de 1.48v. Añadí agua destilada hasta llegar a medio centímetro encima de las placas.

Las he puesto a cargar por pares, sin corriente ni voltaje controlado. Por 5 horas la corriente se ha mantenido en menos de 2A y el voltaje en poco menos de 14. Luego de dejarlas reposar un par de horas, su voltaje de flotación indicaba estaba en 5.5 así que volví a conectar el cargador. Esta vez la corriente subió a 4A y el voltaje se redujo a 13.2. Tras otras 5 horas apagué el cargador. Un día despuès la flotación estaba en 6v así que reanudé la carga, esta vez subió a 8A y el voltaje se mantenía debajo de 14.

Luego de 5 horas he probado la primera pareja de baterías que cargué, conectándoles un inversor pequeño de 350w 220vac, con 80% de carga, el voltaje ha ido bajando en ese lapso de 12.3 a 11.5v de manera gradual.

Voy a incrementar la descarga hasta que el voltaje llegue a 11.0 y cargaré nuevamente. Escribiré los resultados mañana.

09-oct: Con el fin de ecualizarlas sometí las baterías individualmente a 7.4v por 3 horas, durante las cuales han estado recibiendo 10A.

11-oct: Ya he descargado y cargado totalmente la pareja de baterías 3 veces y he observado que hasta el momento brindan 40% de su capacidad nominal.

23-nov: Me fui de viaje, así que dejé las baterías desconectadas. Las encontré con 6.10 voltios así que les puse 10 horas de carga a 6A. La densidad del electrolito llegó a 1.240 en promedio entre celdas. En teoría deben estar en 80% de su capacidad nominal así que las descargaré un 30%, eso significa 75Ah. Usaré una carga de 8A, con lo cual en teoría debería conseguir al menos 8 ó 9 hras de trabajo.